#37365 [NEW]: apache2 cannot load libphp4.so

From: Date: Mon, 08 May 2006 13:47:02 +0000
Subject: #37365 [NEW]: apache2 cannot load libphp4.so
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-96815@lists.php.net to get a copy of this message
From: mluisfer at gmail dot com Operating system: tru64 v5.1A PHP version: 4.4.2 PHP Bug Type: Apache2 related Bug description: apache2 cannot load libphp4.so Description: ------------ I'm using apache2 2.0.58 IBM Informix CSDK Version 2.80, IBM Informix-ESQL Version 9.52.FC2 commands make and make install works fine, but when I want to statup the apache2 send the next message : exception system: exiting due to internal error: exception dispatch or unwind stuck in infinite loop exception system: exiting due to internal error: exception dispatch or unwind stuck in infinite loop ./apachectl: 326203 Abort - core dumped The php cli binary (/usr/local/apache2/bin/php) generated by the make install works fine, I can run a php script with the following command "/usr/local/apache2/bin/php testifx.php", it has a single connection to informix database and make a sql. is possible to mention that php libphp4.so works without the --with-informix option. Actual result: -------------- my configure options: ./configure --prefix=/usr/local/apache2/php --with-apxs2=/usr/local/apache2/bin/apxs --disable-rpath --with-ndbm --with-yp --enable-ftp --enable-calendar --with-pear --enable-mbstring --with-zlib-dir=/usr/local/lib --with-informix=yes this is the apache2 log: Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: dlopen: libaio.so: symbol "aio_prefork" unresolved compiled modules in php cli binary (php -m): [PHP Modules] calendar ctype dba ftp informix mbstring mysql overload pcre posix session standard tokenizer xml zlib -- Edit bug report at http://bugs.php.net/?id=37365&edit=1 -- Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=37365&r=trysnapshot44 Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=37365&r=trysnapshot51 Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=37365&r=trysnapshot52 Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=37365&r=trysnapshot60 Fixed in CVS: http://bugs.php.net/fix.php?id=37365&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=37365&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=37365&r=needtrace Need Reproduce Script: http://bugs.php.net/fix.php?id=37365&r=needscript Try newer version: http://bugs.php.net/fix.php?id=37365&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=37365&r=support Expected behavior: http://bugs.php.net/fix.php?id=37365&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=37365&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=37365&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=37365&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=37365&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=37365&r=dst IIS Stability: http://bugs.php.net/fix.php?id=37365&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=37365&r=gnused Floating point limitations: http://bugs.php.net/fix.php?id=37365&r=float No Zend Extensions: http://bugs.php.net/fix.php?id=37365&r=nozend MySQL Configuration Error: http://bugs.php.net/fix.php?id=37365&r=mysqlcfg

« previous php.bugs (#96815) next »