#37365 [Opn->Bgs]: apache2 cannot load libphp4.so
| From: | tony2001@php.net | Date: | Mon, 15 May 2006 21:57:52 +0000 |
| Subject: | #37365 [Opn->Bgs]: apache2 cannot load libphp4.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-97146@lists.php.net to get a copy of this message | ||
ID: 37365
Updated by: tony2001@php.net
Reported By: mluisfer at gmail dot com
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: tru64 v5.1A
PHP Version: 4.4.2
New Comment:
"aio_prefork" symbol and libaio.so have nothing to do with PHP.
Not PHP problem.
Previous Comments:
------------------------------------------------------------------------
[2006-05-08 14:33:52] mluisfer at gmail dot com
using IBM Informix CSDK Version 2.90, IBM Informix-ESQL Version
2.90.FC4
the process to startup apache2 dont drop a core dump but hangs and need
a ctrl-c o ctrl-z to kill the process. In the logs file send the same
messages about symbol "aio_prefork" unresolved.
------------------------------------------------------------------------
[2006-05-08 13:47:02] mluisfer at gmail dot com
Description:
------------
I'm using
apache2 2.0.58
IBM Informix CSDK Version 2.80, IBM Informix-ESQL Version 9.52.FC2
commands make and make install works fine, but when I want to statup
the apache2 send the next message :
exception system: exiting due to internal error: exception dispatch or
unwind stuck in infinite loop
exception system: exiting due to internal error: exception dispatch or
unwind stuck in infinite loop
./apachectl: 326203 Abort - core dumped
The php cli binary (/usr/local/apache2/bin/php) generated by the make
install works fine, I can run a php script with the following command
"/usr/local/apache2/bin/php testifx.php", it has a single connection to
informix database and make a sql.
is possible to mention that php libphp4.so works without the
--with-informix option.
Actual result:
--------------
my configure options:
./configure --prefix=/usr/local/apache2/php
--with-apxs2=/usr/local/apache2/bin/apxs --disable-rpath --with-ndbm
--with-yp --enable-ftp --enable-calendar --with-pear --enable-mbstring
--with-zlib-dir=/usr/local/lib --with-informix=yes
this is the apache2 log:
Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: dlopen:
libaio.so: symbol "aio_prefork" unresolved
compiled modules in php cli binary (php -m):
[PHP Modules]
calendar
ctype
dba
ftp
informix
mbstring
mysql
overload
pcre
posix
session
standard
tokenizer
xml
zlib
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37365&edit=1