#37434 [NEW]: curl module doesn't work
| From: | nastasache_iulian at yahoo dot com | Date: | Sun, 14 May 2006 10:19:22 +0000 |
| Subject: | #37434 [NEW]: curl module doesn't work | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-97051@lists.php.net to get a copy of this message | ||
From: nastasache_iulian at yahoo dot com
Operating system: Linux
PHP version: 5.1.4
PHP Bug Type: cURL related
Bug description: curl module doesn't work
Description:
------------
PHP curl module doesn't work after upgrading to mysql 5.1.9.
All other php modules working fine.
System: Linux Redhat 9
Tested with: PHP 5.0.4, PHP 5.1.4 and PHP 5.2 -. Same error.
I think it is mysql related, but both curl and mysql working as
apllication and I have both installed correctly.
On other systems what I have (Gentoo, RHE), php 5.1.4 and mysql 5.1.9
combination is working corectly.
Reproduce code:
---------------
I think is enough to try:
./configure --with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config --with-curl
Here is my full configure:
./configure --prefix=/usr/local/apache/php
--with-config-file-path=/usr/local/apache/conf
--with-apxs2=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config --with-pgsql --with-mcrypt
--with-mhash --with-bz2 --with-cybercash --with-curl --with-db4 --with-dba
--with-dom --with-freetype-dir=/usr --with-ftp --with-gd --with-gdbm
--with-gettext --with-iconv --with-jpeg-dir=/usr --with-mod_charset
--with-openssl --with-png --with-png-dir=/usr --with-pspell
--with-regex=system --with-ttf --with-zlib --with-xml
--with-xslt-sablot=/usr/local/sablot --enable-bcmath --enable-bcmath=yes
--enable-debug=no --enable-ftp --enable-gd-native-ttf
--enable-inline-optimization --enable-magic-quotes --enable-mbstring
--enable-memory-limit=yes --enable-pic --enable-safe-mode --enable-sockets
--enable-sysvsem --enable-sysvshm --enable-trans-sid --enable-track-vars
--enable-yp --enable-wddx --enable-xslt
gmake
gmake install
Expected result:
----------------
correct installation of curl module.
Actual result:
--------------
Error at end of gmake install:
[activating module `php5' in /usr/local/apache/conf/httpd.conf]
Installing PHP CLI binary: /usr/local/apache/php/bin/
Installing PHP CLI man page: /usr/local/apache/php/man/man1/
Installing PEAR environment: /usr/local/apache/php/lib/php/
PHP Fatal error: Unable to start curl module in Unknown on line 0
gmake[1]: *** [install-pear-installer] Error 254
gmake: *** [install-pear] Error 2
Error in apache log:
PHP Fatal error: Unable to start curl module in Unknown on line 0
--
Edit bug report at http://bugs.php.net/?id=37434&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=37434&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=37434&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=37434&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=37434&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=37434&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=37434&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=37434&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=37434&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=37434&r=support
Expected behavior: http://bugs.php.net/fix.php?id=37434&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=37434&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=37434&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=37434&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=37434&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=37434&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=37434&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=37434&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=37434&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=37434&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=37434&r=mysqlcfg