#37434 [Opn->Bgs]: curl module doesn't work
| From: | tony2001@php.net | Date: | Sun, 14 May 2006 12:41:26 +0000 |
| Subject: | #37434 [Opn->Bgs]: curl module doesn't work | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-97058@lists.php.net to get a copy of this message | ||
ID: 37434
Updated by: tony2001@php.net
Reported By: nastasache_iulian at yahoo dot com
-Status: Open
+Status: Bogus
Bug Type: cURL related
Operating System: Linux
PHP Version: 5.1.4
New Comment:
Works perfectly fine here.
>PHP Fatal error: Unable to start curl module in Unknown on line 0
This means that curl_global_init() failed, which in turn means that you
have problems with curl itself and the problem has nothing to do with
PHP.
Previous Comments:
------------------------------------------------------------------------
[2006-05-14 10:19:22] nastasache_iulian at yahoo dot com
Description:
------------
PHP curl module doesn't work after upgrading to mysql 5.1.9.
All other php modules working fine.
System: Linux Redhat 9
Tested with: PHP 5.0.4, PHP 5.1.4 and PHP 5.2 -. Same error.
I think it is mysql related, but both curl and mysql working as
apllication and I have both installed correctly.
On other systems what I have (Gentoo, RHE), php 5.1.4 and mysql 5.1.9
combination is working corectly.
Reproduce code:
---------------
I think is enough to try:
./configure --with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config --with-curl
Here is my full configure:
./configure --prefix=/usr/local/apache/php
--with-config-file-path=/usr/local/apache/conf
--with-apxs2=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config --with-pgsql
--with-mcrypt --with-mhash --with-bz2 --with-cybercash --with-curl
--with-db4 --with-dba --with-dom --with-freetype-dir=/usr --with-ftp
--with-gd --with-gdbm --with-gettext --with-iconv --with-jpeg-dir=/usr
--with-mod_charset --with-openssl --with-png --with-png-dir=/usr
--with-pspell --with-regex=system --with-ttf --with-zlib --with-xml
--with-xslt-sablot=/usr/local/sablot --enable-bcmath
--enable-bcmath=yes --enable-debug=no --enable-ftp
--enable-gd-native-ttf --enable-inline-optimization
--enable-magic-quotes --enable-mbstring --enable-memory-limit=yes
--enable-pic --enable-safe-mode --enable-sockets --enable-sysvsem
--enable-sysvshm --enable-trans-sid --enable-track-vars --enable-yp
--enable-wddx --enable-xslt
gmake
gmake install
Expected result:
----------------
correct installation of curl module.
Actual result:
--------------
Error at end of gmake install:
[activating module `php5' in /usr/local/apache/conf/httpd.conf]
Installing PHP CLI binary: /usr/local/apache/php/bin/
Installing PHP CLI man page: /usr/local/apache/php/man/man1/
Installing PEAR environment: /usr/local/apache/php/lib/php/
PHP Fatal error: Unable to start curl module in Unknown on line 0
gmake[1]: *** [install-pear-installer] Error 254
gmake: *** [install-pear] Error 2
Error in apache log:
PHP Fatal error: Unable to start curl module in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37434&edit=1