#37672 [NEW]: Cannot start script from directory containing international characters.
| From: | php-bugs at shad dot pp dot ru | Date: | Fri, 02 Jun 2006 08:41:40 +0000 |
| Subject: | #37672 [NEW]: Cannot start script from directory containing international characters. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-97957@lists.php.net to get a copy of this message | ||
From: php-bugs at shad dot pp dot ru
Operating system: Windows 2000 SP4 + hotfixes
PHP version: 5.1.4
PHP Bug Type: Unknown/Other Function
Bug description: Cannot start script from directory containing international characters.
Description:
------------
Scripts within directories containing international characters cannot be
executed. I got these messages in error log:
[Fri Jun 02 12:25:49 2006] [error] [client 195.131.159.151] PHP Warning:
Unknown: failed to open stream: No such file or directory in Unknown on
line 0, referer: http://musicstation.spb.ru/files/
[Fri Jun 02 12:25:49 2006] [error] [client 195.131.159.151] PHP Warning:
Unknown: Failed opening
'D:/www/musicstation.spb.ru/files/\xd1\x80\xd1\x83\xd1\x81\xd1\x81\xd0\xba\xd0\xbe\xd0\xb5_\xd0\xb8\xd0\xbc\xd1\x8f/index.php'
for inclusion (include_path='.;C:\\php5\\pear') in Unknown on line 0,
referer: http://musicstation.spb.ru/files/
This is not a problem of apache, because I can access normal html
documents and other files in such directories.
My configuration is:
Windows 2000 SP4 + hotfixes / Apache 2.0.48 / PHP 5.1.4 installed as
Apache2 module / NTFS filesystem.
--
Edit bug report at http://bugs.php.net/?id=37672&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=37672&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=37672&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=37672&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=37672&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=37672&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=37672&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=37672&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=37672&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=37672&r=support
Expected behavior: http://bugs.php.net/fix.php?id=37672&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=37672&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=37672&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=37672&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=37672&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=37672&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=37672&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=37672&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=37672&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=37672&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=37672&r=mysqlcfg