Bug #14881 Updated: Apache fails to start after PHP compile

From: Date: Fri, 07 Jun 2002 22:29:02 +0000
Subject: Bug #14881 Updated: Apache fails to start after PHP compile
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-9801@lists.php.net to get a copy of this message
ID: 14881 Updated by: sniper@php.net Reported By: dw59@earthlink.net -Status: Open +Status: Closed Bug Type: Apache related Operating System: Cobalt (Red Hat) Linux 6.0 PHP Version: 4.1.1 New Comment: This bug has been fixed in CVS. You can grab a snapshot of the CVS version at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites. Thank you for the report, and for helping us make PHP better. Previous Comments: ------------------------------------------------------------------------ [2002-06-07 16:58:15] dw59@earthlink.net This issue has apparently been corrected by a suggestion from another user...their suggestion worked for my recompile on 4.2.1: I had the same problem getting Apache to start after compiling 4.1.2. I then found this snippet: in file php-4.1.2/ext/gd/php_gd.h find near line 66 the following: PHP_MSHUTDOWN_FUNCTION(gd); #ifndef HAVE_GDIMAGECOLORRESOLVE static int gdImageColorResolve(gdImagePtr, int, int, int); #endif then change the static to extern so the line now reads: extern int gdImageColorResolve(gdImagePtr, int, int, int); then recompile. Thanks to Mark who posted on http://i4net.tv/... mailto:mark@NO_SPamThanks.logictotal.freeserve.co.uk Thanks, Dennis Williams ------------------------------------------------------------------------ [2002-01-05 21:56:11] dw59@earthlink.net After compile of PHP 4.1.1 Apache failed to start with the following warning: /etc/rc.d/init.d/httpd start Setting up Web Service: Syntax error on line 58 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: gdImageColorResolve /usr/sbin/httpd Configure line: ./configure --prefix=/usr --with-mysql --with-apxs=/usr/sbin/apxs --with-gd --with-gettext=/usr --enable-safe-mode --with-config-file-path=/etc/httpd --with-exec-dir=/usr/bin --with-zlib --enable-magic-quotes --with-regex=system --with-ttf=/usr/lib/libttf.so --enable-track-vars --enable-xml --disable-debug --with-db --with-interbase=shared --with-pgsql=shared --with-ldap --with-imap I removed --with-gd and everything worked fine. Possible due to GD compatability? PHP 4.0.6 compiled OK with same gd library currently installed on system. Thanks, Dennis Williams ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=14881&edit=1

« previous php.bugs (#9801) next »