Re: cvs: php4 /ext/mbstring mbstring.c mbstring.h
| From: | Colin Viebrock | Date: | Tue, 01 May 2001 15:07:22 +0000 |
| Subject: | Re: cvs: php4 /ext/mbstring mbstring.c mbstring.h | ||
| References: | 1 | Groups: | php.cvs |
| Request: | Send a blank email to php-cvs+get-5425@lists.php.net to get a copy of this message | ||
> >+ PHP_FE(mbstrlen, NULL)
> >+ PHP_FE(mbstrpos, NULL)
> >+ PHP_FE(mbstrrpos, NULL)
> >+ PHP_FE(mbsubstr, NULL)
> >+ PHP_FE(mbstrcut, NULL)
> >+ PHP_FE(mbstrwidth, NULL)
> >+ PHP_FE(mbstrimwidth, NULL)
>
> You should leave the underscores. This is our naming convention. i.e.
> mb_strlen()
Could I make a further suggestion about the naming of these functions:
> > PHP_FE(mbstr_convert_encoding, NULL)
> > PHP_FE(mbstr_detect_encoding, NULL)
> > PHP_FE(mbstr_convert_kana, NULL)
> > PHP_FE(mbstr_encode_numericentity, NULL)
> > PHP_FE(mbstr_decode_numericentity, NULL)
> > PHP_FE(mbstr_send_mail, NULL)
The "str" part is redundant in things like "mbstr_strlen", so you've
changed
it to "mb_strlen". If all the functions started with "mb_" that would be a
Good Thing, I think. I propose:
mb_convert_encoding
mb_detect_encoding
mb_convert_kana
mb_encode_numeric_entity
mb_decode_numeric_entity
mb_mail
There are others, I'm sure, but CVS seems to be down, so I can't update and
get the full list.
- Colin