PHP+Postgresql/Win32
| From: | Jancs | Date: | Thu, 30 Aug 2001 21:47:10 +0000 |
| Subject: | PHP+Postgresql/Win32 | ||
| Groups: | php.db | ||
| Request: | Send a blank email to php-db+get-11999@lists.php.net to get a copy of this message | ||
Hi there!
I am trying to use such combination of software: Apache 1.3.20/PHP4.06/Postgres 7.1.3/Win2K. I met a serious problem - some postgres database admin script (php) says "Unable to connect to server".
I think i did everything i could - apache is running without problems, php is configured to use pgsql.dll. Anyway - something is wrong with php, it seems. I am making such decision because i am getting such error message in both cases - when postgres is running (with running cyg-ipc service) on not.
What makes it more difficult - i m trying to start it on the machine having no NIC and therefore using IP 127.0.0.1.
Everything other works well. Netstat says that postgres is listening on 127.0.0.1:5432 More, i can use the pgadmin tool by GreatBridge (designed for nt/w2k, but using ODBC).
Jancs
Laps Cileecish
http://jancs.ktf.rtu.lv