Re: Sybase CT with/without Sybase ASE
| From: | Dean Bennett | Date: | Fri, 14 Sep 2001 13:54:08 +0000 |
| Subject: | Re: Sybase CT with/without Sybase ASE | ||
| References: | 1 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-12454@lists.php.net to get a copy of this message | ||
You don't need the Sybase dataserver but you still need the Sybase shared libraries that PHP is linked against.
So restore all the .so's in $SYBASE/lib, and apache should start. Offhand, I'm not sure if 12.5 came with a different version of the open client libraries than 11.9.2 did, but if it did you may need to keep the 11.9.2 libs around.
Dean
At 12:49 PM 14/09/01 +0200, Carlo Borreo wrote:
Dear All, In the past I had installed an Apache server with PHP 4.0.6 and Sybase CT extension on Mandrake Linux 8, all ok. On the Mandrake machine, I had installed Sybase ASE 11.9.2, that was only used for test; most of the time the php code used sybase ct lib to refer to another database server (Sybase ASE 12.5 on Solaris), and all worked. But now I tried to update the test Sybase ASE database server on Mandrake from 11.9.2 from 12.5. I was not successful, but I could live without test database, so I didn't worry. But at next reboot, Apache was failing to start with this message: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: libinsck.so: cannot load shared object file: No such file or directory /etc/init.d/httpd start: httpd could not be started The file libphp4.so is in place, but file libinschk.so is not on the machine. I thought that PHP and sybase ct didn't need a database server to be installed on the machine; was I wrong? I also tried uninstalling completely 12.5, but still Apache doesn't start. As I said, I can live without that database server, but I need Apache, Php, and Sybase ct, please help. Thanks in advance Carlo Borreo -- PHP Database Mailing List (http://www.php.net/) To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net For additional commands, e-mail: php-db-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net