Re: dlls and inis.Help.
| From: | DL Neil | Date: | Fri, 16 Nov 2001 06:40:26 +0000 |
| Subject: | Re: dlls and inis.Help. | ||
| References: | 1 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-14380@lists.php.net to get a copy of this message | ||
> Anyone got a clue for this piece of "bad luck"?
> I'm on win2k pro + IIS5 +php4.0.6 cgi installation. It works fine
> untill I try to load php_interbase.dll extension and this is how it goes:
> "Unable to load dynamic library '...' - The specified procedure
> could not be found". Three points stand for:
> ./ (this one is by default),
> d:\php,
> d:\php\extensions,
> d:\winnt and
> d:\winnt\system32,
> wherever I choose to put the dll. Those folders where declared in
> the above fashion and with/without quotes, with slash/backslash.
> ( other *.ini-s, for example, to assign folders don't use quotes and
> use \ instead of /) - ( Of course I had Interbase server running all the
> time.),
> and I wasn't lazy to reboot the system every time...
> Now count the combinations...
> Tiresome...
> Does anybody know how to solve this?
Hi Zoran
Is it possibly an issue with PHP.INI. From mine:-
-----
...
;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;
...
; Directory in which the loadable extensions (modules) reside.
;extension_dir = ./
extension_dir = C:/program files/php/extensions
; Whether or not to enable the dl() function. The dl() function does NOT work
; properly in multithreaded servers, such as IIS or Zeus, and is automatically
; disabled on them.
enable_dl = On
...
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
;
...
;Windows Extensions
;Note that MySQL and ODBC support is now built in, so no dll is needed for it.
;
;extension=php_bz2.dll
...
;extension=php_interbase.dll
...
------
Uncomment the last (shown) line and place the .dll in the extension_dir directory.
Hope it helps,
=dn