RE: [PHP-DB] Problem w/ mysql_pconnect

From: Date: Sun, 23 Jun 2002 14:21:19 +0000
Subject: RE: [PHP-DB] Problem w/ mysql_pconnect
References: 1  Groups: php.db 
Request: Send a blank email to php-db+get-20009@lists.php.net to get a copy of this message
Hi Paul, I'm no MySQL expert and i'm only very new to this list but i have had the same problem before. What i did to fix the problem was replace "localhost" with the ip address of the machine...so on my network i my MySQL server is 10.3.2.1 so i used "10.3.2.1" instead of "localhost" and it worked for me. the real solution i guess would be to grant access for that username from the "localhost.localdomain" address in your MySQL server. see how u go. -----Original Message----- From: Paul D [mailto:agonza04@bellsouth.net] Sent: Monday, 24 June 2002 12:07 AM To: php-db@lists.php.net Subject: [PHP-DB] Problem w/ mysql_pconnect I'm using PHP 4.2.0 with MYSQL 3.23. When I try to use either the mysql_connect or mysql_pconnect to access the database, I get the following error message: Access denied for user: 'pauld@localhost.localdomain' (Using password: YES) I have tried different user names and nothing seems to work. If I use the functions without any parameters, it'll work just fine, and when I try access directly from the console, it'll work fine also. The problem seems to lie with the function parameters, which is written as follows: $db = mysql_pconnect("localhost", "pauld", "any_pwd") or die($php_errormsg); Any suggestions would be very much appreciated. -- PHP Database Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

« previous php.db (#20009) next »