Re: Problem w/ mysql_pconnect
| From: | Tracker 1 | Date: | Mon, 24 Jun 2002 08:47:40 +0000 |
| Subject: | Re: Problem w/ mysql_pconnect | ||
| References: | 1 2 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-20037@lists.php.net to get a copy of this message | ||
Yes, the actual resolution of how the system is accessed is restricted,
usually the accounts are restricted by user@"localhost", however, you
can iirc use user@"%" for access from anywhere, as part of the grant
statement... you can also change the account's host in the mysql.user
table.
Be carefull about using @"%", unless you are behind a firewall and
blocking the port used by mysql (3306 by default).. you can change
the port to a non-standard port for mysql, but I have had issues with
various connection drivers, so, I am just more carefull with my firewall
restrictions.
--
=======================================================================
Michael J. Ryan - tracker1[*at*]theroughnecks.com
Roughneck BBS: http://www.theroughnecks.net
telnet://theroughnecks.net
=======================================================================
Y!: aztracker1 - aim: azTracker1 - icq: 4935386 - msn: see email
One program for aim/icq/yahoo/msn/irc - http://www.trillian.cc/
"Chris Barnes" <runtimeerror@bigpond.com> wrote in message
news:000201c21ac1$3f0c0d80$0a02030a@back2front.homelinux.org...
> Hi Paul,
> I'm no MySQL expert and i'm only very new to this list but i have had the
> same problem before.
> What i did to fix the problem was replace "localhost" with the ip address of
> the machine...so on my network i my MySQL server is 10.3.2.1 so i used
> "10.3.2.1" instead of "localhost" and it worked for me.
>
> the real solution i guess would be to grant access for that username from
> the "localhost.localdomain" address in your MySQL server.
>
> see how u go.
>
> -----Original Message-----
> From: Paul D [mailto:agonza04@bellsouth.net]
> Sent: Monday, 24 June 2002 12:07 AM
> To: php-db@lists.php.net
> Subject: [PHP-DB] Problem w/ mysql_pconnect
>
>
> I'm using PHP 4.2.0 with MYSQL 3.23. When I try to use either the
> mysql_connect or mysql_pconnect to access the database, I get the
> following error message:
>
> Access denied for user: 'pauld@localhost.localdomain' (Using password: YES)
>
> I have tried different user names and nothing seems to work. If I use
> the functions without any parameters, it'll work just fine, and when I
> try access directly from the console, it'll work fine also. The problem
> seems to lie with the function parameters, which is written as follows:
>
> $db = mysql_pconnect("localhost", "pauld", "any_pwd") or
> die($php_errormsg);
>
> Any suggestions would be very much appreciated.
>
>
> --
> PHP Database Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>