Bug #3292: MySQL module causes DSO to fail.
| From: | mike at mikehardy dot net | Date: | Mon, 24 Jan 2000 13:20:20 +0000 |
| Subject: | Bug #3292: MySQL module causes DSO to fail. | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-14865@lists.php.net to get a copy of this message | ||
From: mike@mikehardy.net
Operating system: Linux
PHP version: 3.0.12
PHP Bug Type: Dynamic loading related
Bug description: MySQL module causes DSO to fail.
Two others have seen this, but I can't add a comment, and I wanted to both confirm and note
that it happens on the new Apache. Here's the old bugs:
http://bugs.php.net/bugs.php3?id=2187
http://bugs.php.net/bugs.php3?id=3168
...and I can confirm it on RH6.1, kernel 2.2.14, Apache 1.3.11, PHP 3.0.12
with MySQL 3.22.30. I also have IMAP compiled in, but I'm not sure that matters.
The behavior is exactly as described here. Apache fails to start up normally, but if I comment out
the PHP module directives it starts. Then if I uncomment them and HUP the httpd process, PHP works.