Re: php4isapi.dll and Website Pro 2.4: report
| From: | Andi Gutmans | Date: | Mon, 14 Feb 2000 04:56:59 +0000 |
| Subject: | Re: php4isapi.dll and Website Pro 2.4: report | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-15510@lists.php.net to get a copy of this message | ||
Hi,
According to the WebSite Pro homepage their ISAPI doesn't support filters. There will need to be a WSAPI implemented for it, if I'm not mistaken. Have you thought of doing this? It would probably be quite similar to the ISAPI one which is just one file, php4isapi.c in sapi/isapi.
Andi
At 09:34 PM 2/13/00 -0500, chrism wrote:
Andi, I've just tried out your recent 'php-pre2-beta4.zip' on a Website Pro install. This is the first time i've attempted to get an ISAPI version up and running on this machine - I know you've had to solve a lot of thread issues to get this far. Here's my results: Versions of Website Pro prior to 2.4 will complain about the ISAPI version. Specifically the error returned is: "Version ident mismatch in API extension php4isapi.dll" Website Pro 2.4 will now load the dll regardless of version. It records the following message in it's server.log: "ISAPI: ServerSupportFunction() called with unknown opcode 1016" The initial request (which loaded the DLL I presume) sat there, while future requests return the following error: "php4isapi.dll generated a fatal exception (-1073741819)." So in any event, I gather the ISAPI support within Website Pro 2.4 is not complete enough to run your current IIS/ISAPI PHP build. If you want to attempt to work-around this i'll be happy to try another binary. The box I am using is running NT4/SP5 with 2 processors. I didn't activate the mysql dll within php.ini. Chris McGonagle chrism@FOUR.net--- Andi Gutmans <andi@zend.com> http://www.zend.com/