PHP 4.0.0 on Solaris 2.6 with gcc 2.95.2

From: Date: Fri, 16 Jun 2000 21:12:12 +0000
Subject: PHP 4.0.0 on Solaris 2.6 with gcc 2.95.2
Groups: php.dev 
Request: Send a blank email to php-dev+get-21568@lists.php.net to get a copy of this message
Dear Fellow PHPers, You may recall that months ago I posted to the developer's list about my attempts to build a "kitchen sink" version of PHP (PHP with all the possible bells and whistles) under Solaris 2.6 using gcc_2.95.2. I had a ton of problems and gave up for a while. Recently, my colleague Ziying Sherwin and I took it up again, and have had fairly good success. *If* there is interest, we will post an ftpable "web kit" of all the source code and installation notes for Apache/PHP/MySQL and the affilated applications, as a sort of installation "snapshot" for others working with the same platform. (We are not in a position to offer support for this, but would be happy to share our labor). There are still a few problems (summarized below) installing these three packages: mcrypt, readline, and db2. If anyone has insight into these problems, we'd much appreciate hearing from you. Also, due to mail to the PHP lists, we did not even try to install mod_dav support in PHP, as it was clear that it would not work. Does anyone know if this is going to be rewritten (and if so, when)? Best Regards, Rick Rodgers (rodgers@nlm.nih.gov) Ziying Sherwin (sherwin@nlm.nih.gov) -------------------------------------------------------------------------------- Here is the configuration command we used: setenv CPPFLAGS "-I/depot/include" setenv LDFLAGS "-L/depot/lib" sh ./configure \ --prefix=/site/subsys/www/php_4.0.0 \ --with-config-file-path=/site/subsys/www/php_4.0.0 \ --with-apxs=/site/subsys/www/apache_1.3.12/bin/apxs \ --with-mysql=/site/subsys/www/mysql_3.22.32 \ --with-exec-dir=/site/subsys/www/apache_1.3.12/php-bin \ --enable-track-vars \ --disable-short-tags \ --enable-bcmath=yes \ --enable-sysvshm=yes \ --enable-sysvsem=yes \ --enable-safe-mode=yes \ --with-mhash=/depot/package/mhash_0.6.1 \ --with-gd=/depot/package/gd_1.7.3 \ --with-gdbm=/depot/package/gdbm_1.8 \ --with-ldap=/site/subsys/openLDAP_1.2.7 \ --with-pdflib=/depot/package/pdflib_2.01 \ --with-jpeg-dir=/depot/package/jpeg_6b \ --with-tiff-dir=/depot/package/tiff_3.5.5 \ --with-gettext=/depot/package/gettext_0.10.35 \ --with-mm=/site/subsys/www/mm_1.1.2 \ --enable-ftp \ --with-zlib=/depot/package/zlib_1.1.3 \ --with-xml=/site/subsys/www/expat_1.1 We excluded the following packages (mcrypt, readline, db2): --with-mcrypt=/depot/package/mcrypt_2.2.5 \ because it caused load-time problems with Apache: nob[root]csh:411> /site/subsys/www/apache_1.3.12/bin/apachectl start Syntax error on line 210 of /site/subsys/www/apache_1.3.12/conf/httpd.conf: Cannot load /site/subsys/www/apache_1.3.12/libexec/libphp4.so into server: ld.so.1: /site/subsys/www/apache_1.3.12/bin/httpd: fatal: relocation error: file /site/subsys/www/apache_1.3.12/libexec/libphp4.so: symbol __eprintf: referenced symbol not found /site/subsys/www/apache_1.3.12/bin/apachectl start: httpd could not be started and: --with-db2=/depot/package/berkeley_db_2.7.7 \ because the Apache server not load the php module: nob[root]csh:537>/site/subsys/www/apache_1.3.12/bin/apachectl start Syntax error on line 210 of /site/subsys/www/apache_1.3.12/conf/httpd.conf: Cannot load /site/subsys/www/apache_1.3.12/libexec/libphp4.so into server: ld.so.1: /site/subsys/www/apache_1.3.12/bin/httpd: fatal: relocation error: file /site/subsys/www/apache_1.3.12/libexec/libphp4.so: symbol db_open: referenced symbol not found /site/subsys/www/apache_1.3.12/bin/apachectl start: httpd could not be started and: --with-readline=/depot/package/readline_4.0 \ because of name collisions during linker stage with gd. ------------------------------------------------------------------------

« previous php.dev (#21568) next »