PHP 4.0 Bug #7050: DL_UNLOAD symbol not found

From: Date: Fri, 06 Oct 2000 05:18:40 +0000
Subject: PHP 4.0 Bug #7050: DL_UNLOAD symbol not found
Groups: php.dev 
Request: Send a blank email to php-dev+get-34327@lists.php.net to get a copy of this message
From: peter.kocks@baygate.com Operating system: Solaris 2.7 PHP version: 4.0.3RC2 PHP Bug Type: Compile Problem Bug description: DL_UNLOAD symbol not found In compiling and running 4.0.3RC2, I get the following error. This problem did not exist in 4.0.3RC1. When launching apache, I get an error message: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/bin/httpd: fatal relocation error: file /usr/local/apache/libexec/libphp4.so: symbol DL_UNLOAD: referenced symbol not found INFORMIXDIR=/opt/informix/prod ; export INFORMIXDIR ; \ PATH=/opt/informix/prod/bin:$$PATH ; export PATH ; \ LIBS="-L/usr/local/lib -L/opt/informix/prod/lib -L/opt/informix/prod/lib/esql -L/var/baygate/www/lib -R/usr/local/lib -R/opt/informix/prod/lib -R/opt/informix/prod/lib/esql -R/var/baygate/www/lib" ; export LIBS ; \ EXTRA_LIBS="-lgd -lpng -lz" ; export EXTRA_LIBS ; \ PROG_SENDMAIL=/usr/local/lib/sendmail ; export PROG_SENDMAIL ; \ ./configure \ --with-apxs=/usr/local/apache/bin/apxs \ --with-config-file-path=/var/baygate/www/conf \ --enable-track-vars \ --enable-trans-sid \ --without-mysql \ --with-gd \ --with-ttf \ --with-ndbm \ --with-informix=/opt/informix/prod \ --with-system-regex \ --enable-sysvsem \ --enable-sysvshm )

« previous php.dev (#34327) next »