PHP 4.0 Bug #7087: error opening libclntsh.so.8.0

From: Date: Sun, 08 Oct 2000 16:16:03 +0000
Subject: PHP 4.0 Bug #7087: error opening libclntsh.so.8.0
Groups: php.dev 
Request: Send a blank email to php-dev+get-34472@lists.php.net to get a copy of this message
From: lpc2@stal.ru Operating system: SCO UnixWare7.1.0 PHP version: 4.0.2 PHP Bug Type: Compile Failure Bug description: error opening libclntsh.so.8.0 I use --with-oci8: get attention. See attach file debug.log: CONFIGURE: './configure' '--prefix=/u/wwww/php' '--with-apxs=/u/wwww/bin/apxs' '--with-mod_charset' '--with-oci8' '--enable-tracks-vars' '--enable-ftp' '--enable-sysvsem' '--enable-sysvshm' '--enable-sigchild' CC: cc CFLAGS: -g CPPFLAGS: CXX: CXXFLAGS: INCLUDES: -I/u/wwww/include -I$(top_builddir)/Zend -I$(top_srcdir) -I/u/source/php/ext/mysql/libmysql -I/oracle8/app/oracle/product/8.1.5/rdbms/demo -I/oracle8/app/oracle/product/8.1.5/network/public -I/oracle8/app/oracle/product/8.1.5/plsql/public LDFLAGS: -L/usr/ucblib -L/usr/ucblib -L/oracle8/app/oracle/product/8.1.5/lib -L/oracle8/app/oracle/product/8.1.5/lib LIBS: -lclntsh -lthread -ldshm -lgen -lm -lelf -ldl -lgen -lnsl -lsocket -lresolv -lresolv -lm -ldl -lcrypt -lsocket -lsocket DLIBS: SAPI: apache PHP_RPATHS: /usr/ucblib /oracle8/app/oracle/product/8.1.5/lib uname -a: UnixWare adm 5 7.1.0 i386 x86at SCO UNIX_SVR5 cc -o conftest -g -L/usr/ucblib -L/usr/ucblib -L/oracle8/app/oracle/product/8.1.5/lib -L/oracle8/app/oracle/product/8.1.5/lib conftest.c -lclntsh -lthread -ldshm -lgen -lm -lelf -ldl -lgen -lnsl -lsocket -lresolv -lresolv -lm -ldl -lcrypt -lsocket -lsocket 1>&5 UX:cc: WARNING: Use -Kthread instead of -lthread when linking with threads library; using -lthread directly may cause incorrect execution behavior. dynamic linker : ./conftest : error opening libclntsh.so.8.0 ----------------- if use --with-mysql: ./configure --prefix=/u/wwww/php \ --with-mysql \ --with-apxs=/u/wwww/bin/apxs \ --with-mod_charset \ --enable-tracks-vars \ --enable-ftp \ --enable-sysvsem \ --enable-sysvshm \ --enable-sigchild make make install # ./apachectl start Syntax error on line 1325 of /u/wwww/conf/httpd.conf: Cannot load /u/wwww/libexec/libphp4.so into server: dynamic linker: /u/wwww/bin/ httpd: relocation error: symbol not found: pow; referenced from: /u/wwww/libexec/libphp4.so ./apachectl start: httpd could not be started ??????? -- Edit Bug report at: http://bugs.php.net/?id=7087&edit=1

« previous php.dev (#34472) next »