PHP 4.0 Bug #7551 Updated: Can't start apache with libphp4.so

From: Date: Fri, 03 Nov 2000 08:30:27 +0000
Subject: PHP 4.0 Bug #7551 Updated: Can't start apache with libphp4.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-36918@lists.php.net to get a copy of this message
ID: 7551 User Update by: fr-delaby@chru-lille.fr Status: Open Bug Type: Apache related Description: Can't start apache with libphp4.so I tried with --oci8 instead of --oracle, but the result is the same. I had --enable-versioning too (I use php3)... Previous Comments: --------------------------------------------------------------------------- [2000-10-31 12:18:21] fr-delaby@chru-lille.fr Here is the return message > bin/apachectl start Syntax error on line 225 of /usr/opt/apache/conf/httpd.conf: Cannot load /usr/opt/apache/libexec/libphp4.so into server: dlopen: cannot load /usr/opt/apache/libexec/libphp4.so bin/apachectl start: httpd could not be started > I saw no problems during compilation of php (only warnings). Apache ran well with php3.0.15 I compiled all with cc. I use dynamic library, apache 1.3.12, perl 5.6.0, oracle 8.0.5.1. My configure options was ./configure --with-apxs=/usr/opt/apache/bin/apxs --with-xml --with-oracle=/usr/opt/oracle/product/8.0.5. For Apache, I used ./configure --prefix=/usr/opt/apache --enable-shared=max --with-perl=/usr/bin/perl --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7551

« previous php.dev (#36918) next »