PHP 4.0 Bug #6490 Updated: Apache startup fails with undefined symbol in libphp4.so

From: Date: Thu, 09 Nov 2000 00:53:29 +0000
Subject: PHP 4.0 Bug #6490 Updated: Apache startup fails with undefined symbol in libphp4.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-37489@lists.php.net to get a copy of this message
ID: 6490 Updated by: sniper Reported By: dp@recycled.net Status: Closed Bug Type: *General Issues Assigned To: Comments: If this is still a problem, please upgrade to PHP4.0.3pl1 and read this page carefully: http://www.php.net/ref.imap.php Hint: Check the header files for imap.. If problem still exists and you think it really is a bug in PHP, reopen this report. --Jani Previous Comments: --------------------------------------------------------------------------- [2000-09-01 14:24:48] dp@recycled.net PHP 4.0.2 configured: ./configure --with-apxs=/www/apache/bin/apxs --with-ldap=/usr/local --with-imap=/usr/local --with-pgsql=/apps/pgsql Versions of called libraries/includes: OpenLDAP: 1.2.11, IMAP: UW-IMAP 4.7c2, PostgreSQL: 7.0.2, Apache: 1.3.12. # /www/apache/bin/apachectl configtest (or start) /usr/libexec/ld.so: Undefined symbol "_unixdriver" in httpd:/www/apache/libexec/libphp4.so There are other similar mentions of this in the bug database; one suggestion was to include the necessary -L/-l/-I calls in Apache as well as in PHP; I tried this and encountered the same results. Any help appreciated; it looks like this has come up before, and hopefully has since been resolved. --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=6490

« previous php.dev (#37489) next »