PHP 4.0 Bug #6397 Updated: Cannot start Apache due to _dl_default_scope

From: Date: Thu, 09 Nov 2000 02:22:53 +0000
Subject: PHP 4.0 Bug #6397 Updated: Cannot start Apache due to _dl_default_scope
Groups: php.dev 
Request: Send a blank email to php-dev+get-37494@lists.php.net to get a copy of this message
ID: 6397 Updated by: sniper Reported By: michael@intellnet.net.uk Status: Feedback Bug Type: *General Issues Assigned To: Comments: Have you tried recompiling Apache and making sure I really supports DSO? --Jani Previous Comments: --------------------------------------------------------------------------- [2000-08-28 07:52:23] michael@intellnet.net.uk Compiling php as a loadable module: ./configure --with-mysql --with-apxs System compiles fine. When attempting to re-start apache with the new module: Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib/apache/1.3/libphp4.so: undefined symbol: _dl_default_scope. As static, php compiles fine but apache compile drops out : /usr/lib/libdl.a(dlsym.o): In function `doit.2': dlsym.o(.text+0x22): undefined reference to `_dl_default_scope' dlsym.o(.text+0x4c): undefined reference to `_dl_default_scope' make[2]: *** [target_static] Error 1 make[2]: Leaving directory `/usr/apache_1.3.12/src' make[1]: *** [build-std] Error 2 make[1]: Leaving directory `/usr/apache_1.3.12' make: *** [build] Error 2 Bit stumped, even tried previous versions of php4 to no avail. With thanks Michael --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=6397

« previous php.dev (#37494) next »