PHP 4.0 Bug #7712: Problem with DSO and Apache -- occurs in upgrade from 4.0.3 to 4.0.3pl1

From: Date: Thu, 09 Nov 2000 06:48:48 +0000
Subject: PHP 4.0 Bug #7712: Problem with DSO and Apache -- occurs in upgrade from 4.0.3 to 4.0.3pl1
Groups: php.dev 
Request: Send a blank email to php-dev+get-37504@lists.php.net to get a copy of this message
From: tobkin@tobkin.com Operating system: Solaris 2.6 x86 PHP version: 4.0.3pl1 PHP Bug Type: Apache related Bug description: Problem with DSO and Apache -- occurs in upgrade from 4.0.3 to 4.0.3pl1 ./apachectl start Syntax error on line 228 of /home/src/apache/conf/httpd.conf: Cannot load /home/src/apache/libexec/libphp4.so into server: ld.so.1: /home/src/apache/bin/httpd: fatal: relocation error: file /home/src/apache/libexec/libphp4.so: symbol sapi_get_stat: referenced symbol not found ./apachectl start: httpd could not be started This occurs with any combination of configure options from something as simple as: ./configure --with-apxs=/home/src/apache/bin/apxs to more complex options. The common thread is that I'm compiling it as a shared object for apache (which is compiled with DSO support). It seems to be something that changed from 4.0.3 to 4.0.3pl1. I'm able to successfully go back to 4.0.3 as a dynamic shared object for apache just fine. Feel free to contact me if you have ideas for a solution or need more information. Thanks, // Chris tobkin@tobkin.com -- Edit Bug report at: http://bugs.php.net/?id=7712&edit=1

« previous php.dev (#37504) next »