Re: Re: PHP 4.0 Bug #8144 Updated: apache dumps core after libphp.so loaded

From: Date: Thu, 07 Dec 2000 15:09:26 +0000
Subject: Re: Re: PHP 4.0 Bug #8144 Updated: apache dumps core after libphp.so loaded
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-40384@lists.php.net to get a copy of this message
Nevermind...I got it to patch. But I did have patch failrurse in filestat.c (hunk #1) and and php.h (hunk #1). Are you patching against the current, or RC4? Perhaps I should just wait a few days for 4.0.4 to come out, unless you need me to test the LARGEFILE changes and ensure they actually work before that! David. ----- ** PLEASE NOTE ** This message was composed with the aid of a speech recognition system. Please be aware there may be some strange word usage. Many thanks.... On Thu, 7 Dec 2000, Sascha Schumann wrote: > On Thu, 7 Dec 2000, David Birnbaum wrote: > > > Howdy, > > > > Now I'm having a runtime problem, where 4.0.4RC4 fails with the following missing > > symbol: > > > > Syntax error on line 31 of /export/httpd/etc/srm.conf: > > Cannot load /opt/httpd/1.3.14/libexec/libphp4.so into server: ld.so.1: > > /opt/httpd/1.3.14/sbin/httpd: > > fatal: relocation error: file /opt/httpd/1.3.14/libexec/libphp4.so: > > symbol php_if_stat64: referenced symbol not found > > Try applying the attached patch. I'll commit it later to > 4.0.4 branch. > > > Another person mentioned that my core dumping might be due to the > > LARGEFILE support running an apache, which 4.0.4 is supposed to handle > > properly. > > It probably was related to that. > > - Sascha >

« previous php.dev (#40384) next »