PHP 4.0 Bug #8540: --enable-versioning and dynamic php extensions won't work on Solaris

From: Date: Wed, 03 Jan 2001 19:56:55 +0000
Subject: PHP 4.0 Bug #8540: --enable-versioning and dynamic php extensions won't work on Solaris
Groups: php.dev 
Request: Send a blank email to php-dev+get-42873@lists.php.net to get a copy of this message
From: hartmut@six.de Operating system: Solaris 7 PHP version: 4.0.4 PHP Bug Type: Dynamic loading Bug description: --enable-versioning and dynamic php extensions won't work on Solaris When trying to get both PHP 3 and 4 Modules working in a single Apache it is not possible to load php 4 extensions dynamicly as shared objects removing php 3 from the server setup does not help, the problem is related to --enable-versioning this is broken on solaris but works fine on linux ... the error message is PHP Warning: Unable to load dynamic library '.../no-debug-non-zts-20001214/sixcode.so' - ld.so.1: .../bin/httpd: fatal: relocation error: file .../no-debug-non-zts-20001214/sixcode.so: symbol alloc_globals: referenced symbol not found in Unknown on line 0 -- Edit Bug report at: http://bugs.php.net/?id=8540&edit=1

« previous php.dev (#42873) next »