Re: RE: [PHP-QA] Re: [PHP-DEV] ctype function (re?)naming
| From: | Boian Bonev | Date: | Fri, 02 Mar 2001 02:19:15 +0000 |
| Subject: | Re: RE: [PHP-QA] Re: [PHP-DEV] ctype function (re?)naming | ||
| References: | 1 | Groups: | php.dev php.qa |
| Request: | Send a blank email to php-dev+get-47747@lists.php.net to get a copy of this message | ||
Just +1 :)
----- Original Message -----
From: "Stanislav Malyshev" <stas@zend.com>
To: "Ron Chmara" <ron@Opus1.COM>
Cc: "PHP Development" <php-dev@lists.php.net>; <php-qa@lists.php.net>
Sent: Thursday, March 01, 2001 1:47 PM
Subject: Re: [PHP-DEV] RE: [PHP-QA] Re: [PHP-DEV] ctype function (re?)naming
> RC>> It's more legible for the same reason that it's easier (and
> RC>> faster) to read "one two three" than "onetwothree". The human
> RC>> mind can easily tokenize at the appropriate places, when it has
> RC>> a token. Without a token, the string is much harder to parse.
>
> For me, "isalpha" is single token. That's the name, much like Johnson or
> Chandrabharmata.
>
> RC>> There's several, in order of use: ldap_connect, ldap_bind,
ldap_search.
> RC>> Without looking in the manual, I _don't_ have to guess if it's
ldap_search
> RC>> or ldapsearch. Which is my entire point. I know the ldap functions
were
>
> Exactly. Because you don't know the "search" part, wondering on underscore
> is useless. That's my point. I repeat it once more, to be clear:
> ========
> Functions that have "well known" names should not be touched. That
> includes fopen (not open_file, neither file_open or filesystem_open_file,
> thankyouverymuch), isaplha, ImageGif, etc., etc. Functions that do not
> have established names (like most third-party libraries) can be named by
> any standard that feels warm on your heart, I have no objection on this.
> ========
>
> RC>> I didn't check a manual. Ldap functions aren't named in a mixed
fashion
> RC>> of word_wordword and word_word_word. They follow the *most common*
PHP
> RC>> syntax of using word_word_word.
>
> Don't try to make me believe you remember all the "non-underscore" part of
> all functions by hard and your only problem is knowing where's the
> underscore.
>
> RC>> To stop confusing the *language*, as a whole, we should be doing this
with
> RC>> some consistency, so we're not confusing people as they try to learn
new
> RC>> function names. They shouldn't have to guess, or read the manual,
just
> RC>> to figure out the "proper spacing" in invoking it.
>
> That's not "confusing". That's "remaining in touch with the rest of
> the
> known world". I do not want function to open file be
> "filesystem_open_file". I want my old trusty fopen. It served me well for
> years.