PHP 4.0 Bug #10273: configure script fails with Apache 2.0.16
| From: | akenning at dog dot topology dot org | Date: | Tue, 10 Apr 2001 20:43:02 +0000 |
| Subject: | PHP 4.0 Bug #10273: configure script fails with Apache 2.0.16 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-51402@lists.php.net to get a copy of this message | ||
From: akenning@dog.topology.org
Operating system: SuSE 7.1 linux, kernel 2.4.0
PHP version: 4.0.4pl1
PHP Bug Type: *Configuration Issues
Bug description: configure script fails with Apache 2.0.16
./configure --with-apache=/home/akenning/soft/httpd --with-gd --with-pgsql=/usr/local/pgsql
Symptoms when running this are:
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache module support via DSO through APXS... no
checking for Apache module support... no
configure: error: Invalid Apache directory - unable to find httpd.h under /home/akenning/soft/httpd
It's obvious that the "configure" script just looks in the wrong place for httpd.h.
It should look for
$withval/include/httpd.h
not for this file:
$withval/src/include/httpd.h
To fix this, the "configure" file needs to be changed.
--
Edit Bug report at: http://bugs.php.net/?id=10273&edit=1