PHP 4.0 Bug #10273 Updated: configure script fails with Apache 2.0.16

From: Date: Tue, 10 Apr 2001 20:51:28 +0000
Subject: PHP 4.0 Bug #10273 Updated: configure script fails with Apache 2.0.16
Groups: php.dev 
Request: Send a blank email to php-dev+get-51403@lists.php.net to get a copy of this message
ID: 10273 Updated by: jason Reported By: akenning@dog.topology.org Old-Status: Open Status: Bogus Bug Type: *Configuration Issues Assigned To: Comments: --with-apache is for Apache 1.3.X. Use --with-apxs2. Apache 2 support is currently experimental. -Jason Previous Comments: --------------------------------------------------------------------------- [2001-04-10 16:43:02] akenning@dog.topology.org ./configure --with-apache=/home/akenning/soft/httpd --with-gd --with-pgsql=/usr/local/pgsql Symptoms when running this are: Configuring SAPI modules checking for AOLserver support... no checking for Apache module support via DSO through APXS... no checking for Apache module support... no configure: error: Invalid Apache directory - unable to find httpd.h under /home/akenning/soft/httpd It's obvious that the "configure" script just looks in the wrong place for httpd.h. It should look for $withval/include/httpd.h not for this file: $withval/src/include/httpd.h To fix this, the "configure" file needs to be changed. --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=10273&edit=2

« previous php.dev (#51403) next »