Bug #11069: can't spawn new php after a few hours (mem leak?)
| From: | mike at kristopeit dot com | Date: | Wed, 23 May 2001 22:32:33 +0000 |
| Subject: | Bug #11069: can't spawn new php after a few hours (mem leak?) | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-56550@lists.php.net to get a copy of this message | ||
From: mike@kristopeit.com
Operating system: win98
PHP version: 4.0.5
PHP Bug Type: Apache related
Bug description: can't spawn new php after a few hours (mem leak?)
i run a web based game with a development server that gets around 100k hits a day.
after upgrading to apache 1.3.19 and php 4.0.5 and mysql 3.23.38 the server suddenly stops working
and returns "internal server error" after a few hours, and apaches error.log reads
"can't spawn child process"
i am using php as CGI now. i used to use the module, but when i use the module now, the server
works fine for about 10 minutes and then stops working completely (doesn't even return 500
internal server error)
these are the only 3 programs that are running and this didn't happen before i upgraded all the
software.
i am using persistant connections on the db which i believe may be linked to the problem.
--
Edit Bug report at: http://bugs.php.net/?id=11069&edit=1