Bug #12048: Can't have a subdir called PHP in HTDOCS

From: Date: Wed, 11 Jul 2001 13:15:45 +0000
Subject: Bug #12048: Can't have a subdir called PHP in HTDOCS
Groups: php.dev 
Request: Send a blank email to php-dev+get-59695@lists.php.net to get a copy of this message
From: php@dwatkinson.co.uk Operating system: Win2000 PHP version: 4.0.6 PHP Bug Type: Apache related Bug description: Can't have a subdir called PHP in HTDOCS A colleague set up a directory within htdocs called PHP which contained several html & PHP files. We got a 404 Error every time we wanted to access anything within that directory, and the Apache error log said that the browser was trying to access the file (say test.php) from c:\php\test.php. Turns out it was because the directory was called PHP. I renamed it and all was fine. I guess it's a mix-up with the ScriptAlias in httpd.conf? Not sure if it's an Apache or a PHP problem, so I thought I'd let you both know! Didn't find anything on this online anywhere either. Cheers! Dave -- Edit bug report at: http://bugs.php.net/?id=12048&edit=1

« previous php.dev (#59695) next »