Bug #12048 Updated: Can't have a subdir called PHP in HTDOCS
ID: 12048
Updated by: jeroen
Reported By: php@dwatkinson.co.uk
Old Summary: Can't have a subdir called PHP in HTDOCS
Old Status: Open
Status: Bogus
Bug Type: Apache related
Operating System: Win2000
PHP Version: 4.0.6
New Comment:
apache configuration problem.
You have aliased the /php subdirectory, that means that you will not be able to put files in that
real directory.
The same for /icons, try having a htdocs/icons/ dir, it won't work with the default
installation...
This is not a bug, but a apache-configuration issue. There's no problem when you use the isapi
module, but you can also rename the /php script alias to something wierd, like JBSDLJKJVBDS.
Previous Comments:
------------------------------------------------------------------------
[2001-07-11 09:15:45] php@dwatkinson.co.uk
A colleague set up a directory within htdocs called PHP which contained several html & PHP
files.
We got a 404 Error every time we wanted to access anything within that directory, and the Apache
error log said that the browser was trying to access the file (say test.php) from c:\php\test.php.
Turns out it was because the directory was called PHP. I renamed it and all was fine.
I guess it's a mix-up with the ScriptAlias in httpd.conf? Not sure if it's an Apache or a
PHP problem, so I thought I'd let you both know!
Didn't find anything on this online anywhere either.
Cheers!
Dave
------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=12048&edit=1
Thread (2 messages)