Re: Bug #12121 Updated: chdir and safe_mode

From: Date: Fri, 13 Jul 2001 01:34:03 +0000
Subject: Re: Bug #12121 Updated: chdir and safe_mode
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-59905@lists.php.net to get a copy of this message
> I think that php_checkuid() should be called with > CHECKUID_ALLOW_ONLY_FILE (whcih does not exist yet) instead of > CHECKUID_ALLOW_ONLY_DIR. Meaning -- if the passed "filename" does not > meet UID/GID test, it should *not* try stripping the last element and > trying agian. Sounds right. -Rasmus

« previous php.dev (#59905) next »