Bug #9059 Updated: SNMP compile issue
ID: 9059
Updated by: rasmus
Reported By: l.brockman@videon.ca
Status: Open
Bug Type: SNMP related
Operating System: Tru64 4.0f
PHP Version: 4.0.4pl1
New Comment:
Is this still happening with the latest versions of PHP?
Previous Comments:
------------------------------------------------------------------------
[2001-02-01 17:23:19] l.brockman@videon.ca
When I compile PHP using:
./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-snmp=/usr --with-gd
--with-zlib --enable-static
I get the following error when starting Apache:
bash-2.04# /usr/local/apache/bin/apachectl start
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: Unresolved symbol in
/usr/lib/libsnmp-0.4.2.so: vsnprintf
/usr/local/apache/bin/apachectl start: httpd could not be started
SNMP libs are under /usr/lib and headers are under /usr/include/ucd-snmp
If I take out the --with-snmp=/usr (It used to be in /usr/local/[lib|include], but I moved it to
make sure the linker was finding it) it compiles fine (Just with no snmp support of course).
Any ideas?
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=9059&edit=1
Thread (2 messages)