RE: Bug #9059 Updated: SNMP compile issue
| From: | Laurence Brockman | Date: | Fri, 13 Jul 2001 15:16:14 +0000 |
| Subject: | RE: Bug #9059 Updated: SNMP compile issue | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-59971@lists.php.net to get a copy of this message | ||
I'm not sure... by hacking some stuff a long time ago I got it to compile,
so I haven't tried it since then. And because this server is a production
server, I can't test it out at the moment.
Laurence
-----Original Message-----
From: Bug Database [mailto:php-dev@lists.php.net]
Sent: Thursday, July 12, 2001 11:22 PM
To: l.brockman@videon.ca
Subject: Bug #9059 Updated: SNMP compile issue
ID: 9059
Updated by: rasmus
Reported By: l.brockman@videon.ca
Status: Open
Bug Type: SNMP related
Operating System: Tru64 4.0f
PHP Version: 4.0.4pl1
New Comment:
Is this still happening with the latest versions of PHP?
Previous Comments:
------------------------------------------------------------------------
[2001-02-01 17:23:19] l.brockman@videon.ca
When I compile PHP using:
./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs
--with-snmp=/usr --with-gd --with-zlib --enable-static
I get the following error when starting Apache:
bash-2.04# /usr/local/apache/bin/apachectl start
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: Unresolved
symbol in /usr/lib/libsnmp-0.4.2.so: vsnprintf
/usr/local/apache/bin/apachectl start: httpd could not be started
SNMP libs are under /usr/lib and headers are under /usr/include/ucd-snmp
If I take out the --with-snmp=/usr (It used to be in
/usr/local/[lib|include], but I moved it to make sure the linker was finding
it) it compiles fine (Just with no snmp support of course).
Any ideas?
------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=9059&edit=2