Bug #12531 Updated: undefined symbol: mxdriver

From: Date: Fri, 03 Aug 2001 01:57:35 +0000
Subject: Bug #12531 Updated: undefined symbol: mxdriver
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-61899@lists.php.net to get a copy of this message
ID: 12531 User updated by: curtis@maurand.com Reported By: curtis@maurand.com Old Status: Feedback Status: Open Bug Type: IMAP related Operating System: RedHat 7.1 PHP Version: 4.0.6 New Comment: uname -a produces the following: Linux pisces.maurand.com 2.4.2-2 #1 Sun Apr 8 19:37:14 EDT 2001 i586 unknown Syntax error on line 201 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/ libexec/libphp4.so: undefined symbol: mxdriver /usr/local/apache/bin/apachectl start: httpd could not be started Previous Comments: ------------------------------------------------------------------------ [2001-08-02 16:48:26] sniper@php.net I'm still unable to reproduce this, even with the EXACT same rpms you are using. --Jani ------------------------------------------------------------------------ [2001-08-02 16:14:15] andy@php.net what errors exactly are you getting? ------------------------------------------------------------------------ [2001-08-02 15:22:03] curtis@maurand.com I got them from: ftp://sunsite.unc.edu/pub/distributions/redhat/updates/7.1/en/os/i386 the src rpm comes from ftp://sunsite.unc.edu/pub/distributions/redhat/updates/7.1/en/os/SRPMS However, when you don't call out a directory for imap during configure, PHP will use its own extensions. It doesn't matter. any imap support and I get undefigned symbol: mxdriver. I've downloaded the source tarball from UW and I've compiled it. I have not had a chance to run a make clean and reconfigured from the PHP directory yet. Its still not supposed to be this hard. ------------------------------------------------------------------------ [2001-08-02 15:13:50] curtis@maurand.com I got them from: ftp://sunsite.unc.edu/pub/distributions/redhat/updates/7.1/en/os/i386 the src rpm comes from ftp://sunsite.unc.edu/pub/distributions/redhat/updates/7.1/en/os/SRPMS However, when you don't call out a directory for imap during configure, PHP will use its own extensions. It doesn't matter. any imap support and I get undefigned symbol: mxdriver. I've downloaded the source tarball from UW and I've compiled it. I have not had a chance to run a make clean and reconfigured from the PHP directory yet. Its still not supposed to be this hard. ------------------------------------------------------------------------ [2001-08-02 12:28:32] sniper@php.net I just tried this with RH 7.1: 1. Installed imap-* rpms from RedHat distribution 2. Installed apache 1.3.20 with DSO support 3. Got the 4.0.6 sources and did these steps: # tar zxfv php-4.0.6.tar.gz # cd php-4.0.6 # ./configure \ --prefix=/www/apache \ --with-apxs=/www/apache/bin/apxs \ --with-mysql=/usr/local/mysql \ --with-zlib \ --with-imap \ --with-imap-ssl=/usr \ --with-kerberos \ --with-openssl # make ; make install # /www/apache/bin/apachectl start And no problems at all..so my next question is: WHERE did you get those imap-rpms from?? --Jani ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/?id=12531 Edit this bug report at http://bugs.php.net/?id=12531&edit=1

« previous php.dev (#61899) next »