Bug #12531 Updated: undefined symbol: mxdriver

From: Date: Sat, 11 Aug 2001 16:13:07 +0000
Subject: Bug #12531 Updated: undefined symbol: mxdriver
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-62943@lists.php.net to get a copy of this message
ID: 12531 Updated by: sniper Reported By: curtis@maurand.com Old Status: Open Status: Closed Bug Type: IMAP related Operating System: RedHat 7.1 PHP Version: 4.0.6 New Comment: This is fixed in CVS. Previous Comments: ------------------------------------------------------------------------ [2001-08-02 22:14:00] curtis@maurand.com One more thing. The RedHat php-imap package works. However, it does not have gd support which is the first thing that I'm after even before I work on the webmail project that needs to get done. ------------------------------------------------------------------------ [2001-08-02 22:07:00] curtis@maurand.com A little further information. This was a stock RedHat 7.0 install that I upgraded to 7.1. I've tried compiling PHP against the stock redhat distribution of apache and now the 1.3.20 source that i downloaded. Apache compiled fine and it runs with PHP4 compiled without imap support. I've installed most of the updates that are available at your favorite mirror site including glibc updates. The hardware is a K6II-233 IDE drive system with a 3Com 3c905 and 128MB of RAM. Its a workhorse machine and just gets it done. Its been very stable and hasn't burped while I've been playing around with all of this. I've also got the server running on Port 8000. That said, I had the same problem with the stock apache and it runs on port 80. Hope this is helpful. If you need more details, ask. ------------------------------------------------------------------------ [2001-08-02 21:57:35] curtis@maurand.com uname -a produces the following: Linux pisces.maurand.com 2.4.2-2 #1 Sun Apr 8 19:37:14 EDT 2001 i586 unknown Syntax error on line 201 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/ libexec/libphp4.so: undefined symbol: mxdriver /usr/local/apache/bin/apachectl start: httpd could not be started ------------------------------------------------------------------------ [2001-08-02 16:48:26] sniper@php.net I'm still unable to reproduce this, even with the EXACT same rpms you are using. --Jani ------------------------------------------------------------------------ [2001-08-02 16:14:15] andy@php.net what errors exactly are you getting? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/?id=12531 Edit this bug report at http://bugs.php.net/?id=12531&edit=1

« previous php.dev (#62943) next »