Bug #12825: Cannot load /usr/lib/apache/libphp4.so into server
| From: | owanse at hotmail dot com | Date: | Sat, 18 Aug 2001 14:09:31 +0000 |
| Subject: | Bug #12825: Cannot load /usr/lib/apache/libphp4.so into server | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-63590@lists.php.net to get a copy of this message | ||
From: owanse@hotmail.com
Operating system: linux 2.4
PHP version: 4.0.6
PHP Bug Type: Apache related
Bug description: Cannot load /usr/lib/apache/libphp4.so into server
compiling php4 for dynamic use in apache 1.3.19 went succesfull, ldconfig
and ld /usr/lib/apache/libphp4.so do not complain about any mistakes and
after that reloading apache says:
"Syntax error on line nnn of /etc/httpd/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server:
/usr/lib/apache/libphp4.so: undefined symbol: sasl_set_alloc"
So, i need a gerneral description about this error, i found occurances all
over the buglist and spreading that in several mail lists.
Why is ldd not complaining about undefined symbols, while apache loader
does ?
Even seeking that special symbol in all libraries and knowing that there is
a valid and accesable library for httpd gives me no idea of what went
wrong.
Please submit me a descriptive point of view to that behavior.
--
Edit bug report at: http://bugs.php.net/?id=12825&edit=1