Bug #12825 Updated: Cannot load /usr/lib/apache/libphp4.so into server

From: Date: Sat, 18 Aug 2001 18:19:42 +0000
Subject: Bug #12825 Updated: Cannot load /usr/lib/apache/libphp4.so into server
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-63608@lists.php.net to get a copy of this message
ID: 12825 Updated by: sniper Reported By: owanse@hotmail.com Old Status: Open Status: Feedback Bug Type: Apache related Operating System: linux 2.4 PHP Version: 4.0.6 New Comment: It would help if you told us what your configure line was.. --Jani Previous Comments: ------------------------------------------------------------------------ [2001-08-18 10:09:31] owanse@hotmail.com compiling php4 for dynamic use in apache 1.3.19 went succesfull, ldconfig and ld /usr/lib/apache/libphp4.so do not complain about any mistakes and after that reloading apache says: "Syntax error on line nnn of /etc/httpd/httpd.conf: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: sasl_set_alloc" So, i need a gerneral description about this error, i found occurances all over the buglist and spreading that in several mail lists. Why is ldd not complaining about undefined symbols, while apache loader does ? Even seeking that special symbol in all libraries and knowing that there is a valid and accesable library for httpd gives me no idea of what went wrong. Please submit me a descriptive point of view to that behavior. ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=12825&edit=1

« previous php.dev (#63608) next »