Bug #12950: cannot load libphp4.so into server...
| From: | lwillmann at mailcity dot com | Date: | Fri, 24 Aug 2001 19:13:54 +0000 |
| Subject: | Bug #12950: cannot load libphp4.so into server... | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-64273@lists.php.net to get a copy of this message | ||
From: lwillmann@mailcity.com
Operating system: Red Hat 7.1 i686
PHP version: 4.0.6
PHP Bug Type: Dynamic loading
Bug description: cannot load libphp4.so into server...
Compiled using:
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--enable-versioning \
--with-mysql=/usr/local/mysql \
--enable-track-vars \
--with-imap=/usr/local/imap-2001.BETA.SNAP-0108162300 \
--with-gd \
--with-ldap \
--enable-ftp \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-gettext \
--with-openssl \
--with-mm=/usr/local/lib/mm
--with-jpeg-dir=/usr/lib
It compiles, makes, and installs fine. But when I try to
fire up apache with the module loading.. I get an error
message:
Syntax error on line 212 of
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into
server: libmm.so.11: cannot load shared object file: No
such file or directory
/etc/rc.d/init.d/apachectl start: httpd could not be
started
This is a paste of the EXACT message I am receiving. I
need PHP to get data out of a mysql database, everything
else with PHP is just gravy. I was following a how-to, and
everything else worked ok.. But this. Any help is
appreciated.
--
Edit bug report at: http://bugs.php.net/?id=12950&edit=1