Bug #12950 Updated: cannot load libphp4.so into server...
| From: | sniper@php.net | Date: | Sat, 25 Aug 2001 09:31:11 +0000 |
| Subject: | Bug #12950 Updated: cannot load libphp4.so into server... | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-64299@lists.php.net to get a copy of this message | ||
ID: 12950
Updated by: sniper
Reported By: lwillmann@mailcity.com
Old Status: Open
Status: Bogus
Bug Type: Dynamic loading
Operating System: Red Hat 7.1 i686
PHP Version: 4.0.6
New Comment:
Please ask support questions on the mailing lists:
http://www.php.net/support.php
(Hint: your /etc/ld.so.conf doesn't have the entry
for /usr/local/lib/mm/lib or whatever the path to
libmm.so is. Add that and run /sbin/ldconfig )
Previous Comments:
------------------------------------------------------------------------
[2001-08-24 15:13:54] lwillmann@mailcity.com
Compiled using:
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--enable-versioning \
--with-mysql=/usr/local/mysql \
--enable-track-vars \
--with-imap=/usr/local/imap-2001.BETA.SNAP-0108162300 \
--with-gd \
--with-ldap \
--enable-ftp \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-gettext \
--with-openssl \
--with-mm=/usr/local/lib/mm
--with-jpeg-dir=/usr/lib
It compiles, makes, and installs fine. But when I try to
fire up apache with the module loading.. I get an error
message:
Syntax error on line 212 of
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into
server: libmm.so.11: cannot load shared object file: No
such file or directory
/etc/rc.d/init.d/apachectl start: httpd could not be
started
This is a paste of the EXACT message I am receiving. I
need PHP to get data out of a mysql database, everything
else with PHP is just gravy. I was following a how-to, and
everything else worked ok.. But this. Any help is
appreciated.
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=12950&edit=1