Bug #13893 Updated: win32_apache_mod_ssl + php = crash
| From: | jyrgen at phon dot ioc dot ee | Date: | Thu, 01 Nov 2001 01:40:42 +0000 |
| Subject: | Bug #13893 Updated: win32_apache_mod_ssl + php = crash | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-69445@lists.php.net to get a copy of this message | ||
ID: 13893
User updated by: jyrgen@phon.ioc.ee
Reported By: jyrgen@phon.ioc.ee
Status: Open
Bug Type: Reproducible crash
Operating System: Windows 2000
Old PHP Version: 4.0.6
PHP Version: 4.0.8
New Comment:
if u feel like looking at my server try -> voice.phon.ioc.ee
there you can get the php.ini file ... if it gives you any help ... and a simple php file is there
and a .txt extension-version aswell ...
Previous Comments:
------------------------------------------------------------------------
[2001-10-31 20:28:34] jyrgen@phon.ioc.ee
using php 4.0.8 gave :
-----
Syntax error on line 196 of c:/server/apache/conf/httpd.conf: Cannot load
c:/www/php/sapi/php4apache.dll into server: (127) The specified procedure could not be found:
-----
and using php from commandline (and gave a file.php as a parameter) worked just fine ...
it has made my head spin now for 2 days ... and i am ready to give up :)
------------------------------------------------------------------------
[2001-10-31 19:50:01] jyrgen@phon.ioc.ee
Hi!
there seems to be a conflict in attaching together:
os : w2k
Apache/1.3.22
PHP/4.0.6
mod_ssl/2.8.5
OpenSSL/0.9.6b
the error message :
----------
[Thu Nov 01 02:36:51 2001] [warn] Loaded DSO c:/www/php/sapi/php4apache.dll
uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
Apache/1.3.22 (Win32) PHP/4.0.6 mod_ssl/2.8.5 OpenSSL/0.9.6b running...
----------
<immidiate crash>
----------
shows that php's library uses so called "API" interface and mod-ssl apache
compilation expects EAPI compiled version ...
any ideas how to get past "apache generated errors and will be shut down
<ok>" message ?
or how to get a "-DEAPI" compiled version of php-modules ...
if i try loading php as CGI it gave out error 400
"Invalid URI in request GET /index.php HTTP/1.0"
there seems to be something unfittable for php in apache+mod_ssl for win32 ...
any ideas / hints are welcomed ...
thanks in advance,
Jürgen
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=13893&edit=1