Bug #14716 Updated: PHP 4.1.1 DSO: apache startup fail

From: Date: Wed, 02 Jan 2002 21:44:27 +0000
Subject: Bug #14716 Updated: PHP 4.1.1 DSO: apache startup fail
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-75678@lists.php.net to get a copy of this message
ID: 14716
Updated by: yohgaki
Reported By: tomki@www2.forefrontsw.com
Old Status: Open
Status: Feedback
Bug Type: Apache related
Operating System: Linux, RH 6.1 base, Kernel2.2.19
PHP Version: 4.1.0
New Comment:

Most likely, your dmalloc is too old or have some problems. 
Try to use other/newer dmalloc.

I think you don't need dmalloc option, though. Do you really need it?



Previous Comments:
------------------------------------------------------------------------

[2002-01-02 12:24:20] tomki@www2.forefrontsw.com

OK, it turns out to be the --with-dmalloc option.  I can use [almost] any other options that pertain
to libraries available on my system, but with that one...  php builds fine, but then has the
mentioned problem at runtime.
So would this be some problem with my dmalloc??  Is this a single report of this issue, or what?

------------------------------------------------------------------------

[2002-01-01 02:13:12] tomki@www2.forefrontsw.com

This seems to have been remedied by supplying --with-regex=php.  Supplying --with-regex=apache
caused a build failure.

------------------------------------------------------------------------

[2001-12-27 06:41:23] tomki@www2.forefrontsw.com

/usr/local/apacheS/bin/apachectl start gives me:
Syntax error on line 968 of /usr/local/apacheS/conf/httpd.conf:
BrowserMatch regex could not be compiled.
../bin/apachectl start: httpd could not be started

Before installing the libphp4.so module, the server was fine.  This problem seems to occur
regardless of whether or not I comment the modssl and modperl module lines.
Something about the options below that don't work together?  Please let me know.  :(

I have compiled PHP4.1.1 with this configure line:
./configure --with-mysql=/usr/local --with-ldap --enable-mailparse --with-db3 --with-gdbm
--with-ndbm --with-ttf --with-freetype-dir=/usr/local/include/freetype/ --with-imap
--with-openssl=/usr/local/ssl/ --with-imap-ssl=/usr/local/ssl --with-gd --enable-dmalloc --with-bz2
--enable-ftp --with-apxs=/usr/local/apacheS/bin/apxs --sysconfdir=/etc --with-jpeg-dir=/usr/
--with-zlib-dir=/usr/local --with-png-dir=/usr/local --with-xpm-dir=/usr/X11R6
--with-mcrypt=/usr/local --with-mhash=/usr/local/ --enable-gd-native-ttf --with-java=/usr/jdk1.3/
--enable-track-vars
Everything is OK, no debug.log generated.

------------------------------------------------------------------------



Edit this bug report at http://bugs.php.net/?id=14716&edit=1



Thread (5 messages)

« previous php.dev (#75678) next »