Bug #14951: Apache does not start after PHP compile

From: Date: Wed, 09 Jan 2002 16:36:24 +0000
Subject: Bug #14951: Apache does not start after PHP compile
Groups: php.dev 
Request: Send a blank email to php-dev+get-76364@lists.php.net to get a copy of this message
From:             christian@metamerge.com
Operating system: Solaris 2.8
PHP version:      4.1.1
PHP Bug Type:     Apache related
Bug description:  Apache does not start after PHP compile

After succesfull compilation of PHP 4.1.1, Apache failed to start with the
following warning:

Syntax error on line 222 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol uncompress: referenced symbol
not found


My configure line was:

./configure --enable-trans-sid --with-ldap=/usr/local --with-openssl
--with-apxs=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql

I removed --with-mysql and after recompiling Apache worked fine.  
The MySQL that I use is 3.23.47.

Thanks,

Christian.
-- 
Edit bug report at: http://bugs.php.net/?id=14951&edit=1



Thread (4 messages)

« previous php.dev (#76364) next »