Bug #14951 Updated: Apache does not start after PHP compile

From: Date: Wed, 09 Jan 2002 17:09:29 +0000
Subject: Bug #14951 Updated: Apache does not start after PHP compile
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-76367@lists.php.net to get a copy of this message
ID: 14951
Comment by: christian.flaig@excelsisnet.com
Old Reported By: christian@metamerge.com
Reported By: christian.flaig@excelsisnet.com
Status: Open
Bug Type: Apache related
Operating System: Solaris 2.8
PHP Version: 4.1.1
New Comment:

Me too... 

Same compilation, same error message from Apache.


Previous Comments:
------------------------------------------------------------------------

[2002-01-09 11:36:23] christian@metamerge.com

After succesfull compilation of PHP 4.1.1, Apache failed to start with
the following warning:

Syntax error on line 222 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol uncompress: referenced
symbol not found


My configure line was:

./configure --enable-trans-sid --with-ldap=/usr/local --with-openssl
--with-apxs=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql

I removed --with-mysql and after recompiling Apache worked fine.  
The MySQL that I use is 3.23.47.

Thanks,

Christian.

------------------------------------------------------------------------



Edit this bug report at http://bugs.php.net/?id=14951&edit=1



Thread (4 messages)

« previous php.dev (#76367) next »