Bug #15012 Updated: Cannot load libphp4.so - undefined symbol: uncompress

From: Date: Sun, 13 Jan 2002 22:37:42 +0000
Subject: Bug #15012 Updated: Cannot load libphp4.so - undefined symbol: uncompress
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-76929@lists.php.net to get a copy of this message
ID: 15012 Comment by: dominic.marcotte@ml5.net Reported By: dominic.marcotte@ml5.net Status: Duplicate Bug Type: Apache related Operating System: Debian GNU/Linux 2.2 PHP Version: 4.1.1 New Comment: I tried ./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --with-zlib and when it's compiling, I got the error "Confugure extensions" "checking if the location of ZLIB install directory is defined... no" "checking whether to include ZLIB support... yes" "configure: error: Cannot find libz" so I tried ./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --with-zlib=/usr/local/src/php-4.1.1/ext/zlib and I got the same message :( Can you help me... Previous Comments: ------------------------------------------------------------------------ [2002-01-13 02:40:33] mfischer@php.net Adding --with-zlib fix this for you. ------------------------------------------------------------------------ [2002-01-12 23:12:52] dominic.marcotte@ml5.net I already searched but I didn't find an answer ------------------------------------------------------------------------ [2002-01-12 21:23:49] yohgaki@php.net Please search bug db before report ;) There is workaround described in report :) ------------------------------------------------------------------------ [2002-01-12 21:20:02] dominic.marcotte@ml5.net After compiling and installing PHP on Debian, Apache/1.3.9, MySQL 3.23.44, when I try to restart the apache server, I get the following error : Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=15012&edit=1

« previous php.dev (#76929) next »