Bug #14895 Updated: Error when trying to load the php4 module
| From: | snowgod at snowgod dot org | Date: | Sat, 19 Jan 2002 19:33:23 +0000 |
| Subject: | Bug #14895 Updated: Error when trying to load the php4 module | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-77534@lists.php.net to get a copy of this message | ||
ID: 14895
User updated by: snowgod@snowgod.org
Reported By: snowgod@snowgod.org
Old Status: Feedback
Status: Open
Bug Type: OpenSSL related
Operating System: FreeBSD 4.3-RELEASE
PHP Version: 4.1.1
New Comment:
I've searched the bugdb per your suggestion, Derick. All I found were
two old IMAP-SSL related issues when I searched for the function name
(ssl_onceonlyinit).
I can download a copy of the CVS source if you like and retry my
compile to see if it is fixed.
Something to note, is on a fresh FreeBSD install (4.4-RELEASE), I
installed apache and mod_php from a cvsup'ed ports collection, and I
get the same error, so you may start to get more wide spread reports of
this error.
Let me know.
Previous Comments:
------------------------------------------------------------------------
[2002-01-19 13:08:40] derick@php.net
You need to provide a little more information, read
bugs.php.net/how-to-report.php
Derick
------------------------------------------------------------------------
[2002-01-06 18:37:15] snowgod@snowgod.org
Here is my configuration when compiling php
./configure --with-mysql --enable-track-vars --with-snmp --with-imap
--with-apxs=/usr/local/apache/bin/apxs --enable-ucd-snmp-hack
--with-imap-ssl --with-openssl=/usr --enable-sockets --enable-ftp
--with-bz2 --with-zlib
My apache version is 1.3.20 (I tried with 1.3.22 as well and had the
same issue.
The error I get when attempting to start the apache server (compiles
fine) is:
Cannot load /usr/local/libexec/apache/libphp4.so into server:
/usr/local/libexec/apache/libphp4.so: Undefined symbol
"ssl_onceonlyinit"
libssl exists:
(root@warped) [/usr/lib]$ ls -ld /usr/lib/libssl.so
lrwxrwxrwx 1 root wheel 11 Sep 7 17:59 /usr/lib/libssl.so ->
libssl.so.2
(root@warped) [/usr/lib]$ ls -ld /usr/lib/libssl.so.2
-r--r--r-- 1 root wheel 176348 Apr 21 2001 /usr/lib/libssl.so.2
I can post a list of apache modules if nessicary, but that doesn't seem
to matter, I do use mod_ssl though.
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=14895&edit=1