Bug #14895: Error when trying to load the php4 module

From: Date: Sun, 06 Jan 2002 23:37:16 +0000
Subject: Bug #14895: Error when trying to load the php4 module
Groups: php.dev 
Request: Send a blank email to php-dev+get-76102@lists.php.net to get a copy of this message
From: snowgod@snowgod.org Operating system: FreeBSD 4.3-RELEASE PHP version: 4.1.1 PHP Bug Type: OpenSSL related Bug description: Error when trying to load the php4 module Here is my configuration when compiling php ./configure --with-mysql --enable-track-vars --with-snmp --with-imap --with-apxs=/usr/local/apache/bin/apxs --enable-ucd-snmp-hack --with-imap-ssl --with-openssl=/usr --enable-sockets --enable-ftp --with-bz2 --with-zlib My apache version is 1.3.20 (I tried with 1.3.22 as well and had the same issue. The error I get when attempting to start the apache server (compiles fine) is: Cannot load /usr/local/libexec/apache/libphp4.so into server: /usr/local/libexec/apache/libphp4.so: Undefined symbol "ssl_onceonlyinit" libssl exists: (root@warped) [/usr/lib]$ ls -ld /usr/lib/libssl.so lrwxrwxrwx 1 root wheel 11 Sep 7 17:59 /usr/lib/libssl.so -> libssl.so.2 (root@warped) [/usr/lib]$ ls -ld /usr/lib/libssl.so.2 -r--r--r-- 1 root wheel 176348 Apr 21 2001 /usr/lib/libssl.so.2 I can post a list of apache modules if nessicary, but that doesn't seem to matter, I do use mod_ssl though. -- Edit bug report at: http://bugs.php.net/?id=14895&edit=1

« previous php.dev (#76102) next »