RE: [PHP-DEV] Patches and Extensions and Such
| From: | Dan Hardiker | Date: | Thu, 19 Sep 2002 01:19:50 +0000 |
| Subject: | RE: [PHP-DEV] Patches and Extensions and Such | ||
| References: | 1 2 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-88399@lists.php.net to get a copy of this message | ||
Hi,
On a more careful inspection of the thread, you will see that you can pass
in PARAMETERS (either though the function call of show_source /
highlight_*, or in the query string of the .phps file [eg:
?HIGHLIGHT_FILE=(default|lineno)]). This makes it flexable either which
way.
Neither I (nor Devon) care about weither its on by default or not. We care
about having the *possible* functionality deployed to the masses to help
ease the support nightmare that a server side parsed language causes.
Having its default behavior set to "traditional" or "current behavior" is
not a problem... and an INI directive has NOT been engineering in. The
average user will be blissfully unaware of its existence, unless they read
the changelog / docs / news etc.
[this has been covered previously from many different angles, may I
recommend you try the patch yourself, rather than judging the book by its
cover. Applys nicely over PHP 4.3.0-dev]
- Dan
> On 18/09/02, "Mike Robinson" <mike@mgrobinson.com> wrote:
>> One man's feature is another man's bug. You guys wanted a valid
>> reason, I gave one. There's probably more. :)
>
> Here's a couple more:
>
> How about piecing together code fragments for use in documentation
> tools? The line numbers would get in the way and most likely
> have incorrect numbering.
>
> Also, I use highlight_string and var_export as an easier to read
> alternative to var_dump when looking at big dumps; line numbers
> there wouldn't help.
>
>> Did I miss the part in this thread about why this can't be
>> an option?
>
> Because we frown upon ini file options. (/me creases forehead).
> I quite like the idea of having line numbers turned on using
> a get param for .phps, and have the optional param to highlight_string.
> It's a clean solution, so lets do that.
>
> --Wez.
>
>
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, visit: http://www.php.net/unsub.php
--
Dan Hardiker [dhardiker@staff.firstcreative.net]
ADAM Software & Systems Engineer
First Creative Ltd