Re: naming of new streams functions for 4.3
| From: | Andrei Zmievski | Date: | Sat, 28 Sep 2002 18:40:14 +0000 |
| Subject: | Re: naming of new streams functions for 4.3 | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-88716@lists.php.net to get a copy of this message | ||
On Sat, 28 Sep 2002, Wez Furlong wrote:
> Hi All,
>
> I'm in two minds about what to call the functions introduced by streams
> to user-space.
>
> Some of them are called file_xxx to emphasize the fact that they operate
> on files, while some of them are called stream_xxx to emphasize that they
> are not limited to just files.
>
> Example: streams now allows for (non)blocking mode to be set on "regular"
> files and not just sockets; so socket_set_blocking should now be named
> file_set_blocking. But streams allows for any stream to support
> this operation, so should we call the function stream_set_blocking?
>
> I think all of the new streams related functions should be named consistently,
> but I'm not sure if they should all be named file_xxx or stream_xxx; I think
> we touched on this topic a few months back and, IIRC, the only real issue is
> with the users not realizing that they could/should use the stream_xxx
> functions.
>
> I'd like to get this right before we branch for 4.3; comments please!
I think that having them called stream_* would be more consistent with
the implementation. Making users aware of how these functions work is a
matter of documentation.
-Andrei http://www.gravitonic.com/
* A feature is a bug with seniority. *