naming of new streams functions for 4.3

From: Date: Fri, 27 Sep 2002 23:03:33 +0000
Subject: naming of new streams functions for 4.3
Groups: php.dev 
Request: Send a blank email to php-dev+get-88697@lists.php.net to get a copy of this message
Hi All, I'm in two minds about what to call the functions introduced by streams to user-space. Some of them are called file_xxx to emphasize the fact that they operate on files, while some of them are called stream_xxx to emphasize that they are not limited to just files. Example: streams now allows for (non)blocking mode to be set on "regular" files and not just sockets; so socket_set_blocking should now be named file_set_blocking. But streams allows for any stream to support this operation, so should we call the function stream_set_blocking? I think all of the new streams related functions should be named consistently, but I'm not sure if they should all be named file_xxx or stream_xxx; I think we touched on this topic a few months back and, IIRC, the only real issue is with the users not realizing that they could/should use the stream_xxx functions. I'd like to get this right before we branch for 4.3; comments please! --Wez. -- Wez Furlong The Brain Room Ltd.

« previous php.dev (#88697) next »