New function: bcpowmod()
| From: | Sara Golemon | Date: | Tue, 10 Dec 2002 06:49:11 +0000 |
| Subject: | New function: bcpowmod() | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-92282@lists.php.net to get a copy of this message | ||
I'd like to add a new function to the bcmath module. It's very similar to
the bcpow() function except that it takes advantage of a fast
exponentiation method when used with a modulous.
Based on the function call into libbcmath to bc_raisemod() {bcpow() uses
bc_raise()}, it would seem to make the most sense to call the php version
of the function "bcpowmod()", but with the change in naming conventions
I'm more inclined to call it something closer to "bcmath_raisemod()" or
"bcmath_powmod()".
Am I overcomplicating things by agonizing over the name?
I'd love to hear your thoughts....
-Pollita