Re: New function: bcpowmod()
| From: | Derick Rethans | Date: | Tue, 10 Dec 2002 09:49:03 +0000 |
| Subject: | Re: New function: bcpowmod() | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-92292@lists.php.net to get a copy of this message | ||
On Mon, 9 Dec 2002, Sara Golemon wrote:
> I'd like to add a new function to the bcmath module. It's very similar to
> the bcpow() function except that it takes advantage of a fast
> exponentiation method when used with a modulous.
>
> Based on the function call into libbcmath to bc_raisemod() {bcpow() uses
> bc_raise()}, it would seem to make the most sense to call the php version
> of the function "bcpowmod()", but with the change in naming conventions
> I'm more inclined to call it something closer to "bcmath_raisemod()" or
> "bcmath_powmod()".
>
> Am I overcomplicating things by agonizing over the name?
>
> I'd love to hear your thoughts....
I'd go with bc_powmod().
Derick
--
-------------------------------------------------------------------------
Derick Rethans http://derickrethans.nl/
PHP Magazine - PHP Magazine for Professionals http://php-mag.net/
-------------------------------------------------------------------------